Yealink VOIP Phone Persistent Cross Site Scripting Vulnerability

Yealink VOIP Phone Persistent Cross Site Scripting Vulnerability

Product: Yealink Easy VOIP Phone
Homepage: http://www.yealink.com
Impact: Medium
Authentication: Required
Author: Narendra Shinde

—————————

Vendor description:

Yealink is the professional designer and manufacturer of IP Phone and IP Video Phone for the world-wide broadband telephony market. For more than ten years, Yealink has focused on VoIP products characterized by high cost-performance, easy deployment and affordable price.

———————————–

Vulnerability Information:

1) Multiple Cross Site Scripting vulnerabilities

Impact: Insertion and Execution of malicious scripts in user browser Remotely
Exploitable: Yes
Authentication Required: Yes
User interaction Required : Yes

———————————–

Vulnerability overview/description:

Yealink Easy Voip phone  is prone to multiple cross-site scripting vulnerabilities as the user-supplied input received via certain  parameters is not properly sanitized. This can be exploited by submitting specially crafted input to the affected software.  Successful exploitation could allow the attacker to execute arbitrary script code within the user’s browser session in the security context of the targeted site. The attacker could redirect user to malicious site, gain access to user’s cookies (including authentication cookies), if any, associated with the targeted site, access recently submitted data by the target user via web forms, or take actions on the site masquerading as the target user.

———————————–

Description:

While adding contact information on Contacts page , user input is not properly sanitized.

The « name » field in  Local Phone book and Blacklist form is vulnerable to script injection attacks.

———————————–

Exploitation:

– Login using normal user (Default is user:user)

– Visit Contacts page at http://x.x.x.x/cgi-bin/ConfigManApp.com?Id=9

– Insert « ><img src=0 onerror=alert(/xss/) />

Device use common contact page for normal user and Admin user.Therefore any malicious input from user account on Contact page direclty affects admin user.